Send Email through automation does not work templates in the body of the email

Hi! I have database “Emails”. When a record is added to the database, I need automatically send a “Link1” link in the body of the email. I’ve tried writing the template in different ways but nothing works.
“Link1” link does not come, i.e. the body of the message is empty.


Is this a bug or am I not recording the template correctly?

You should be able to just use {{Link1}}

The rest are probably causing the automation to break/abort

1 Like

I tried it - it doesn’t work.

Can you show us the whole automation (including activity log), a peek at an entity which you’ve tried running it on, and what the resultant email looks like.
We can debug for you.

1 Like

I figured it out. The problem was that the “Link1” field was still empty when the automation was triggered. It sends away an empty field.

Can you suggest Javascript code that will wait until the “Link1” field is filled?
I’ll insert it before triggering the automation to send the email.

Can’t you trigger the automation to run when Link1 field is updated and use a filter of ‘is not empty’?

If I set it this way:

it doesn’t work at all, most likely because “Link1” takes time to fill out (it’s lookup field).

You can use the ‘Emails updated’ trigger (as well or instead of) and choose the Link1 field as the field to monitor.

1 Like

It helped. It worked.

A post was split to a new topic: Timer in automation