Relation Filter Bug

I’m having some issues adding multiple filters to the relation filter. The menu closes after I select the category for the second filter and only seems to remember the second filter if the criteria is already defined (like entities assigned to me). I’ve tried on Safari Version 16.4 and Chrome Version 112.0.5615.121. Here is a gif if the bug.
Relation Filter Bug

1 Like

Aaaaand now I can’t reproduce the error. I would be curious if anyone else has experienced this issue.

1 Like

I’m having the same issue. For me, it seems to be happening on buttons, forms, and table views.
Lists, boards, and to-one entity relations all work fine for me.

1 Like

We are looking into the problem and trying to reproduce it.
Video is more than clear, thanks very much for sharing.
Somehow we can’t get similar behavior, tried various browsers and OS.

If somehow you have clear steps, please share here. Maybe even via shared space template.
In the meantime we will be looking for a problem as well.

1 Like

The problem seemed to occur for recently created relations, especially with a larger number of entities. I think the relation in the video has ~8000 entities with 15+ fields. I had added that relation just a few minutes before. Is it possible there is an indexing delay when making new relations?

Wow. Big-big-big thank you for that info. We indeed render another control (virtualized one) when there are more than 100 options in a select. And filter popup looses it’s anchor after a filter change.

I’ve made a fix and released it, so should be fine now. Thanks again for helping with figuring this out!


Of course, thanks for fixing it so fast!