Can't add new dbs

I have an urgent issue of this error message appearing since today, when trying to add a new database anywhere:

I’m prototyping different space designs and templates, and indeed use a lot of databases, but as far as I see there is no way to see the total count?

Also, I now deleted some databases and the error message still appears. I think that the count 1001 is merely an indication it is higher than 1000?

Anyway, my work in fibery now is stalled because of this.

In order to allow db restore, we soft delete dbs so the count you are seeing will include those.
Reach out via chat, and we can work some magic from our end to clean up soft deleted dbs that you know you won’t need.

Hi, there is de-listed Page available by direct link /audit-soft-deleted-fields which allows you to hard delete Spaces and Fields. So by deleting some Spaces you can get spare space for new databases.

Also we have implemented auto deletion of such Spaces / Databases / Fields if they were soft deleted more than 90 days ago. But it starts deletions only In a month or so

1 Like

That worked, I deleted three soft-deleted spaces that were present, thank you.

It still may be useful to allow an admin insight in the number of databases in use? I got the feeling I will bump into this issue again…

I wonder why you have 1000 databases? What it is for? I can’t imagine a complexity of this space…

1 Like

Database count:

  • I counted them: I got approx. 600 databases in my Workspace, so thats not 1000 at all yet, the error message gives an incorrect sum of databases.
  • Maybe the error message may be counting based on the number of Spaces times the amount of database allocations reserved, not the actual databases count. Is that true?
  • Note that I could do with less spaces and databases (approx. 300), if the following issues are addressed:

Why I have so many Spaces:

Why I have so many databases:

  • I am developing different organizational models and operational processes for an open source decentralized governance and collaboration system (Self Evolving Systems). It is in alpha experimental phase. So my usage of Fibery is prototyping Fibery templates, thats why there are many.
  • Most of these models are connected somehow, or are versions, so I like to keep them in the same Workspace, to test and measure results and efficiency. This is because workspaces can’t be connected in fibery. See also May 9, 2024 / Smart Sections and 15 quality-of-life updates - #39 by Yuri_BC but I will post some uses cases in the future.
  • Databases need to be duplicated for each team or department, again because fibery permisison templates don’t include the entity create permission option yet: May 23, 2024 / Nicer inbox, Feed View, and a dozen small improvements - #14 by Yuri_BC

My resource usage: minimal

  • Apart from the databases and relations in place, I cost Fibery barely any processing costs because the models created are still in development (mainly by myself) and not being used for production. When the entity create permissions are in place, then all fibery representations of the organizational models will be changed and optimized (no duplicate spaces or databases) and tested again.
1 Like

Including soft-deleted ones?

But we do incur processing and storage costs. Do you not get value for money from Fibery?

When I see /audit-soft-deleted-fields there is a bunch of fields (approx 700) soft-deleted, and performed a cleanup using the filter function in the top right corner of that page.

Filtering by database gave no results, so I assume there are not soft deleted databases:

Filtering by Space gave me three soft-deleted spaces, which I deleted, which apparently resolved the issue for now, but I have no idea what soft-deleted databases that contained, as those are not shown and cannot be found using the search.

So I assume there are only soft-deleted fields left, but bulk-deleting them is not possible in that page.

As @Viktar_Zhuk mentioned, soft-deleted will get hard-deleted over time, so if it happens again, you just need to wait.

Yes, the value of Fibery for me personally is currently the ability to develop organizational models that could be worked with using Fibery templates.

Its just that I do not introduce Fibery to development teams yet because of the permissions limitation, which is a blocker for team data privacy.

So my time spent in Fibery the last year is mostly an investment in testing Fibery its potential, creating prototype space templates that may after the permissions update be used by more teams for my open source development of the organizational models.

Also, if commercial services are provided using these models, then this will result in new paid Fibery accounts by new or existing organizations that like to innovate. What I develop with social and organizational cultures and patterns, aligns very well with the new focus of Fibery 2.0.