How can I hide empty rows in a smart folder?

We have the “No Client” and “No Retainer” rows showing up in a smart folder even though there’s no clients that don’t have a linked retainer and there’s no retainers without a linked client. I would expect these to not get displayed if they’re empty as it really clutters up the sidebar for no reason. Is there a setting I need to change here, or is this a bug?


There is no setting to hide these.
Although in your case there may not be any Retainers without a Client (and vice versa) the UI allows for the possibility of creating them (i.e. if you hover over ‘No Client’ you will get the option to create a Retainer which will therefore have no parent Client).
Since Fibery doesn’t have ‘required fields’ there isn’t any way to enforce that this should not be allowed, so the UI makes it possible.