Formulas can't make use of Single Select fields?

It seems not possible to make a Formula that does anything useful with a Single Select field.

E.g., If I want to get the Name of a Single Select field’s current selection I need something like:


but I can’t figure out a way to do that.

I assume the same problem applies to Multi-Selects, though I haven’t tried them.

If this did work, it might make it possible to have something like a “Dynamic Single-Select” type, which could populate its options dynamically for each entity, based on a formula. That’s what I was trying to simulate when I ran into this issue.

ought to work fine, unless I’ve misunderstood.

For multiselects, you would need to aggregate the names:
[MultiSelectField].join("Name",", ")

1 Like

Thanks - it turns out my issue was actually “Can’t change type of Formula field” – i.e., once I’ve defined a Formula Field, I am not allowed to change it to return a different type.

It would be helpful if the error message explained this limitation.