Unable to post images

Hi, curious if anyone else is having this issue:

When I try to add an image to a document page it will load from 0-100% and then disappears. All of my existing images are still there, but I’m unable to add any new ones. I’ve tried multiple different documents both new and existing ones (with and without working images), different filetypes, and different ways of importing (copy & paste, drag and drop, and the embed image option).

Is there a limit to the amount of images I can have? Or if anyone has other suggestions for workarounds to try I’d love to give it a go.


No there is no limit and so far we can’t reproduce it… Can you record a video or gif? It should help us to understand what is going on

Sure thing! Here is a gif of what is happening:


Just to update on this: Tried clearing all the site data (cookies and cache) as well as tried on another browser. Still no luck unfortunately. :frowning:

could you please share an image here? if not please contact us in intercom

The gif above shows the issue, is there an image of something else you’d need?
Also what’s intercom?

Sorry for all the questions :sweat_smile:

It’s the name of the tool we use for in-app support chat (click on the ? in the bottom right of your workspace)

1 Like

I cannot reproduce the issue so maybe the issue is in particular file you’re uploading or in the document or your environment, like OS / Browser / Browser Extensions

Ohh I see - it isn’t any particular file, it happens with any image I use (of various sizes and filetypes). My main browser is Chrome where it was originally working fine but I did try in vanilla Edge with no luck.