Problems duplicating or copying Whiteboards

I’m having a couple of issues with the dashboard.

First I tried to copy part of a whiteboard to a new whiteboard but the “paste” does paste anything. If I paste in the same whiteboard everything works fine.

Then I tried to duplicate the whiteboard. The new whiteboard was created but in an empty state.
I tired to duplicate it again but now I get an error and nothing happens:

Could be related to the change of the colors? The original whiteboard is with the old palette.

In case you want to check what’s copied from the original whiteboard: Untitled (nawdttx2) -

I tried to duplicate a newly created Whiteboard, and I got the HTTP 404 error directly, but if I create a new empty whiteboard, I can paste content from the newly created one.

1 Like

Thanks for reporting a bug.

Duplicate action should be fixed already. Will look into copy-paste.

Hm, actually couldn’t reproduce that copy-paste doesn’t work. I was able to past what you’ve provided. Maybe your current position on the board was way off so it pasted somewhere out of viewport? Could you try Fit-to-screen action after paste? Also make sure that Whiteboard is in focus.

Thank you!

Duplicate error fixed

Paste error is a focus problem as you pointed out. You select the new Whiteboard in the left menu and then you need to click again on the whiteboard. Not sure if it easy to “fix” and put the focus on the whiteboard when you select it from the menu, but my guess is that many people will have this issue.

1 Like

It is not intensional behaviour and actually a bug, it gets in focus bug some other component steals it with a great success.

Bug is added in our backlog. Thanks again.