Enum/Select fields retain original app name

I have been working on a space/app in my development workspace. The space/app name is “Time App”. Once I was happy with the first iteration, I wanted to port it to my normal workspace. So I shared the app as a template and added it to my normal workspace, where I decided to move the database to a space called “System”.

However, it seems that enum (single/multi-select fields) have kept their original space name (i.e. "Time App), so now the scripts fail since they don’t follow the ${app}/${field}_${app}/${holder-type} convention. So instead of:

System/Status_System/Recurrence Rule

The Status field has the following path:

System/Status_Time App/Recurrence Rule

I am not sure if this is a bug or by design. I tried changing the name of the field in the hopes that might reset things but it didn’t seem to have any effect. I also tried to change the name by opening the enum type settings:


But that didn’t work either. I’ve also noticed that this same behaviour happens simply by changing the name of the space/app. I feel that is not ideal behaviour as it will create problems with scripts and require keeping track of legacy names.

Could you guide me as to how to solve this issue.

Hi @cannibalflea


You should not use that template name for a Single/Multi-select fields because it is a bit simplified version of what actually happens. e.g. we also truncate parts if some of them longer than we can handle. In general we do not guaranty this behaviour

Probably, you should rely on a Field Name and through this dynamically discover underlying Database name using schema from fibery.getSchema().