Basic formatting lost when copy-paste checklists (and bullets)

I find myself copying checklists and bullets to other applications (like plain text, MS Teams, Slack) from Fibery (I’m a Windows user, btw), however:

  • copy-paste of checklist works badly
    (no bullet signs, linebreaks often disappear, checked state not captured)
  • copy-paste of bullets does not work well
    (no bullet signs)

Maybe the export works better, but for daily work I want quick copy-paste.

Can this be fixed? Not the end of the world, but occasionally really annoys me.

It’s easier to show than tell (hopefully you’ll see gif-animations below) :wink:

Copy into Plain text editor

Notion does it right

bullets-checklists-to-plain-notion

Fibery

  • Chrome (gif): bullets ok, checklists get linebreaks but nothing else
  • Firefox: bullets ok, checklists lose linebreaks (=everything smushed into one line)

bullets-checklists-to-plain-fibery

Copy into Slack message

Notion

bullets-checklists-to-rich-slack-notion

Fibery

  • Chrome (gif): bullets ok, checklists get linebreaks but nothing else
  • Firefox: bullets ok, checklists get linebreaks but nothing else

bullets-checklists-to-rich-slack-fibery

Copy into MS Teams message

Notion

bullets-checklists-to-rich-msteams-notion

Fibery - checklists paste broken for both Chrome and Firefox

  • Chrome (gif): bullets ok, checklists lose linebreaks (=everything smushed into one line)
  • Firefox: bullets ok, checklists lose linebreaks (=everything smushed into one line)

bullets-checklists-to-rich-msteams-fibery

Slack seems to handle copy-paste the best.
Maybe it all works on MacOS? :thinking:

Tests were done on Windows 10, with Chrome and Firefox.

Hi!
Many thanks for the report :slight_smile:
We definitely have issues with copy-pasting checklists. Bullets at least on Mac are ok. We also checked that Notion really does it better but we have only linebreaks for them ( no checked/unchecked signs). We failed to reproduce losing linebreaks.
Maybe it’s something Windows related only, so we will continue the investigation.

Added bug to the backlog, many thanks for the report! :sparkling_heart:

1 Like

Thanks Polina! :grinning:

Super appreciate if you nail down the lost linebreaks that was hard to reproduce on your end, maybe a Windows thing as you said.

Lost linebreaks is such a pain, as long as linebreaks are there its at least readable and its easier to add whatever was lost (bullets etc).

1 Like

For housekeeping - I see this issue (or it seems to be the same/very similar) was reported earlier. Don’t want to bump that old post but if someone wants to merge or similar, we had a report from 2021 here (also a Windows user!):

1 Like