[NOTABUG?] New Type creation experience - annoyances and enhancements

#1

Hi,

These are the annoyances while creating a new Type within an app:

  1. Immediately after creating a new type, there is a non-seamless refresh of the popup and it goes back to the default type of the app, rather than allowing the user to finish setting up the actual configurations for the newly created type.

  2. “Show this type in the left menu” tickbox label is not really self-explanatory. At least, it should say, “List items of this type in the left navigation sidebar.”

  3. The drop-down list of “Add Relation to” configuration block should first list the other types of the same app, and then the other types of other apps (perhaps in descending order of total number of links between the app of the newly created type to the other apps).

  4. The abrupt switch to the default type screen happens every time after adding a field or relation or extension to the type - this can even mislead user to add configuration items to the default type of the app, which are actually intended for the newly created type (happened to me).

  5. After adding a Relation, for example a one to many relation to some other type, the label of the relation doesn’t maintain the Title Case that is by default shown in the Relation Collection name text box. The label is set as “Other types” instead of “Other Types”. The same issue happens at the other end of that relation as well.

  6. It’s not clear how to customize the Workflow for the type (it can be done in a Board view). But it should be configurable in the type definition popup under Workflow.

  7. Relative ordering of the actual view presentation of the fields and relations should be configurable in the Type setup screen itself by drag-and-drop reordering.

Thanks!
Shafqat

2 Likes
#2

@Shafqat_Ullah Thanks for the feedback!

1 and 4. Can you record a short video? We can’t reproduce this problem

  1. Good idea, we will replace the text

  2. Good idea as well, we will do it.

  3. This is known and we will make states customizable from Workflow setting.

  4. So far you can DnD fields on Entity View. We have several similar requests and most likely will implement it in future.

2 Likes
#3

@mdubakov

Here’s the recording for issues #1 and #4 above:

#4

@Shafqat_Ullah We can’t reproduce this bug so far, but it is really annoying. What browser you use?

#5

Safari. I’ll try in Chrome and reconfirm.

#6

Yup! Doesn’t happen in Chrome! Safari-specific. @mdubakov

#7

We didn’t reproduce it in Safari neither… Can you try to open Incognito Tab in Safari and do it again? Alternatively, you may try to clear cache in Safari.

#8

Doesn’t happen in Safari Incognito on a fresh sign in!

#9

Interesting. Can you do the last try? Safari with cleared cache?
https://clear-my-cache.com/apple-mac-os/safari.html

#10

Yes, had tried and works fine! No issue!

#11

Great! Still strange :slight_smile: We will investigate why cache was not reset.

#12

Yeah! :+1:

#13

#6 is implemented @Shafqat_Ullah

1 Like
#14

That’s fantastic! :+1: